Loading SWF for the first time...
Adobe Flash is required to run this project in the browser. Enable Flash

This was meant to be a small sideproject, but took a lot longer than expected (as usual)

I hope you enjoy it.

If you feel the strong urge to do so you can follow me on twitter:
https://twitter.com/wombatstuff

StatusReleased
PlatformsFlash
Rating
(3)
AuthorStuffed Wombat
Tags2D, pong