Loading SWF for the first time...
Adobe Flash is required to run this project in the browser. Enable Flash

follow me on twitter if you want


i make one game per month in 2017:
https://twitter.com/wombatstuff


Leave a comment

Log in with itch.io to leave a comment.